Reltio Connect

 View Only
  • 1.  RDM API calls - Access is denied

    Posted 19 days ago

    I'm attempting to execute various RDM APIs, however, I consistently encounter HTTP 403 - Access is denied error message. I have expanded my user permissions to include ROLE_RDM and ROLE_RDM_EDIT.



    ------------------------------
    Derek Bell
    MDM System Administrator
    MSA Safety
    Cranberry Twp PA
    ------------------------------


  • 2.  RE: RDM API calls - Access is denied

    Reltio Employee
    Posted 19 days ago

    just to double check: your permissions are on the RDM tenant, not the MDM tenant, right?



    ------------------------------
    Gino Fortunato
    Principal Solution Engineer
    Reltio
    ------------------------------



  • 3.  RE: RDM API calls - Access is denied

    Posted 19 days ago

    Correct - I have assigned the RDM tenants to those roles.



    ------------------------------
    Derek Bell
    MDM System Administrator
    MSA Safety
    Cranberry Twp PA
    ------------------------------



  • 4.  RE: RDM API calls - Access is denied

    Reltio Employee
    Posted 19 days ago
    you did this with a client credential? Or are you plugging in the One
    Time Passwords via the API?

    Gino Fortunato
    Principal Solutions Consultant
    gino.fortunato@reltio.com
    (855) 360-3282




  • 5.  RE: RDM API calls - Access is denied

    Posted 19 days ago

    I've tried using Authorization Code (since that works for MDM) and Client Credentials, however, both generate that error message.



    ------------------------------
    Derek Bell
    MDM System Administrator
    MSA Safety
    Cranberry Twp PA
    ------------------------------



  • 6.  RE: RDM API calls - Access is denied

    Reltio Employee
    Posted 18 days ago
    Hi,

    Sorry you are having this issue. However, we've reached the end of
    what we can do via community. I would suggest logging a ticket. When
    you find a resolution, I'd appreciate if you would post it here so the
    rest of us can learn.


    Gino Fortunato
    Principal Solutions Consultant
    gino.fortunato@reltio.com
    (855) 360-3282




  • 7.  RE: RDM API calls - Access is denied

    Posted 14 days ago

    I have the solution!

    Apparently, our RDM environment does not reside within the shared rdm.reltio.com.

    In order to check it, you need to pull the physical configuration for the appropriate MDM environment using:

    GET https://{{env}}.reltio.com/reltio/tenants/{{mdmTenant}}

    and locate serviceUri {{rdm_service}} and rdmTenantId {{rdm_tenant_id}} within rdmConfig. For example:  



    ------------------------------
    Derek Bell
    MDM System Administrator
    MSA Safety
    Cranberry Twp PA
    ------------------------------



  • 8.  RE: RDM API calls - Access is denied

    Reltio Employee
    Posted 13 days ago
    Thank you!  I believe the status API would also tell you that.

    Gino Fortunato
    Principal Solutions Consultant
    gino.fortunato@reltio.com
    (855) 360-3282