Reltio Connect

 View Only

 Does profile cloning work with an autogenerated ID?

  •   cloning
  •   id
  •   Profile
Samuel J. Wilson's profile image
Reltio Employee Samuel J. Wilson posted 11-22-2022 12:28
Hi Team, I have an attribute in my sandbox tenant called, HCPID that’s autogenerated. How can I setup profile cloning so that when I clone a profile, it automatically generates a new HcpID?I have the UI config setup like this
"cloneAction": [
                {
                    "entityTypeUris": [
                        "configuration/entityTypes/
HCP"
                    ],
                    "attributeReplacementMapping": {
                        "attributes/HCPID": null
                    },
                    "relationshipTypesToCopy": [
                        "*"
                    ]
I have the L3 configuration setup like this for HCPID
{
                    "label": "HCP ID",
                    "name": "HCPID",
                    "description": "An auto-generated unique id assigned to an HCP",
                    "type": "String",
                    "hidden": false,
                    "important": true,
                    "system": false,
                    "faceted": true,
                    "searchable": true,
                    "autoGenerated": true,
                    "generator": "Sam_Wilson_1",
                    "autoGenerationPattern": "{value}",
                    "generateIfEmpty": true,
                    "generateIfNotEmpty": false,
                    "
generatedValueUniqueForCrosswa
lk": true,
                    "attributeOrdering": {
                        "orderingStrategy": "LUD"
                    },
                    "uri": "configuration/entityTypes/
HCP/attributes/HCPID",
                    "skipInDataAccess": false
                },
But for some reason when I clone a profile, it doesn’t automatically create a new HCPID. Attached below is a brief video that demonstrates this.
Gino Fortunato's profile image
Reltio Employee Gino Fortunato
I may be wrong, but I believe the 'attributeReplacementMapping' to null is preventing the id from being generated.

try removing it.
Samuel J. Wilson's profile image
Reltio Employee Samuel J. Wilson
Thanks @Gino Fortunato when I remove the HCP ID from the attributeReplacementMapping, it copies over the existing autogenerated ID from the profile I'm cloning which is not the desired outcome.  ​​